94 Camaro 3.4l wont pass Emissions in Cali - Page 3 - Camaro Forums - Chevy Camaro Enthusiast Forum


Reply
 
 
 
Thread Tools Search this Thread
  #21  
Old 03-20-2017, 01:22 PM
Thomas O'Connell's Avatar
Newbie
Thread Starter

 
Join Date: Mar 2017
Posts: 18
Default

Im just as confused as you, I know the check engine light works because i can manipulate it with a scan tool. Im not sure as to why there are no codes. As for it being a pcm issue I did think of that but I am saving that for last as I dont want to have to tow my car to a dealer to get the flashing done right.
I put bosch O2 sensors in, I have heard that these are garbage for the camaro, but unfortunately its all I can get my hands on without ordering them online.
Reply With Quote
  #22  
Old 03-21-2017, 10:59 AM
95 camaro 406's Avatar
4th Gear Member

 
Join Date: Aug 2014
Location: troy NH
Posts: 2,004
Default

the gas cap needed to be able to vaper lock it was not so you replaced it right ,i still think you drive it 500 miles take it back should be it ,had it happen to many times times myself on 2 cars ,an if you had the battery unhooked both those things can do it everyone should know that??? guys ,unless you got further issues ,but those are the only reason i se people fail after replaceing that many things ,i was going to say that the gas cap along could have been the issues i never heard of injectors cousing is but i am sure it can happen ,again just takwe it to for some long rides after you get it on the road then take it back ,after that you need some to Diagnose any problems

Last edited by 95 camaro 406; 03-21-2017 at 11:04 AM.
Reply With Quote
  #23  
Old 03-21-2017, 02:49 PM
Thomas O'Connell's Avatar
Newbie
Thread Starter

 
Join Date: Mar 2017
Posts: 18
Default

everything is installed now, all new parts. Now its bogging down really bad. almost like its missfiring
Reply With Quote
  #24  
Old 03-21-2017, 06:04 PM
craby's Avatar
April 2011 ROTM
ROTM Winner's Club

 
Join Date: Mar 2009
Location: Tokeland, Washington
Posts: 19,928
Default

make sure plug wires are going to the right plugs. check fuel pressure, check all your wires
Reply With Quote
  #25  
Old 03-21-2017, 07:16 PM
Thomas O'Connell's Avatar
Newbie
Thread Starter

 
Join Date: Mar 2017
Posts: 18
Default

just need to check fuel pressure but everything else is good. I think the ecm just needed some time to recalibrate to the new parts now its running just fine.
Reply With Quote
  #26  
Old 03-21-2017, 09:44 PM
GaryDoug's Avatar
2nd Gear member

 
Join Date: Aug 2013
Location: Florida
Posts: 479
Default

Yes, check the fuel pressure. If it is low, that could indicate a bad fuel pressure regulator on the injector rail which could be putting raw fuel into the vacuum hose attached. Pull the hose off and see if there is any fuel inside the hose. That could cause the excessive gas smell.
Reply With Quote
  #27  
Old 03-21-2017, 10:57 PM
Thomas O'Connell's Avatar
Newbie
Thread Starter

 
Join Date: Mar 2017
Posts: 18
Default

Everything seems better now that i have driven it a little bit. It has a misfire though with no check engine light, I am thinking coil packs. Will let you guys know when its all said and done.
Reply With Quote
  #28  
Old 03-22-2017, 12:40 PM
Thomas O'Connell's Avatar
Newbie
Thread Starter

 
Join Date: Mar 2017
Posts: 18
Default

So now i have a dead cylinder. Cylinder 6, I just ordered a master rebuild kit which should be in tomorrow. By this weekend I will pretty much have a brand new car... FML
Reply With Quote
  #29  
Old 03-23-2017, 11:18 AM
95 camaro 406's Avatar
4th Gear Member

 
Join Date: Aug 2014
Location: troy NH
Posts: 2,004
Default

sounds like the car is nickle an dimeing you now an other issues with those kinda miles are going to happen ,may want to think about another car the 3800 cars have more parts avaialable
Reply With Quote
  #30  
Old 03-24-2017, 02:49 PM
Thomas O'Connell's Avatar
Newbie
Thread Starter

 
Join Date: Mar 2017
Posts: 18
Default

Nah, not too worried about the money. I got my master rebuild kit in, motor is already out and stripped down to the block. Im about to take the heads and block in to get cleaned up and inspected. The heads look like ****, I still need to pull the crank and pistons but im pretty sure my rings are the cause of all this. In the end though im not to mad, I will essentially have a brand new car when its done.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
My 2002 Camaro SS will not pass emissions wbulger LS Series Tech 2 07-22-2011 09:43 PM
Z28 will NOT pass Emissions. HELP PLEASE shiftdtlb42 LS Series Tech 3 06-18-2011 10:25 AM
305 smoking, will not pass emissions. white1 82-92 V8 Tech 6 05-25-2010 01:51 AM
Possible to pass emissions without computer? martian Computer & Fuel Systems 8 10-03-2006 08:34 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 07:08 PM.