Fuel Pressuse - Camaro Forums - Chevy Camaro Enthusiast Forum


LT1/LT4 Tech 1993-1997

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 01-31-2017, 11:34 AM
Newbie
Thread Starter
 
Join Date: Dec 2016
Location: Asheville nc
Posts: 27
Question Fuel Pressuse

96 Z-28 i have a fuel pressure gauge hooked up when i turn the key on pressure goes to 46 pounds as soon as the solenoid behind the kick panel on the drivers side hits the 2 or 3 second time out the pressure drops to zero is this normal i have not tried to crank it over yet to see what that reads working on some battery issues
Reply With Quote
  #2  
Old 01-31-2017, 12:06 PM
Camaro 69's Avatar
Senior Moderator
January 2010 ROTM Winner
 
Join Date: Oct 2007
Location: The 'Burbs of Chicago
Posts: 17,855
Default

No, pressure should drop a little, but hold for a while. Either bad fuel pressure regulator, or check valve in fuel pump isn't holding. Pull vacuum hose off the f.p.r. and check if fuel is in there. If there is, the regulator is bad.
Reply With Quote
  #3  
Old 01-31-2017, 05:26 PM
Newbie
Thread Starter
 
Join Date: Dec 2016
Location: Asheville nc
Posts: 27
Default Fuel pressure

Quote:
Originally Posted by Camaro 69 View Post
No, pressure should drop a little, but hold for a while. Either bad fuel pressure regulator, or check valve in fuel pump isn't holding. Pull vacuum hose off the f.p.r. and check if fuel is in there. If there is, the regulator is bad.
Ok I will check the FPR I just replaced the FPR so I know it is brand new but yes it can be bad I know that I also replaced all the o rings and filters in the injectors but I will continue to check these things
Thank you for the info
Reply With Quote
  #4  
Old 02-12-2017, 10:34 AM
Newbie
Thread Starter
 
Join Date: Dec 2016
Location: Asheville nc
Posts: 27
Default

Hello again quick question when are the injectors supposed to spray . I turn the switch on but not try to start some of the injectors spray and some dont and the fuel rail will not hold pressure they spray only in the start position correct and what should i buy if i replace them all it is a factory stock 350 LT1 96 Z 28
Reply With Quote
  #5  
Old 02-12-2017, 02:25 PM
craby's Avatar
April 2011 ROTM
ROTM Winner's Club

 
Join Date: Mar 2009
Location: Tokeland, Washington
Posts: 19,977
Default

did this start after you replaced the fpr?
Reply With Quote
  #6  
Old 02-12-2017, 06:59 PM
Newbie
Thread Starter
 
Join Date: Dec 2016
Location: Asheville nc
Posts: 27
Default

No it turns over but will not start
Reply With Quote
  #7  
Old 04-02-2017, 10:24 AM
Newbie
Thread Starter
 
Join Date: Dec 2016
Location: Asheville nc
Posts: 27
Default

Hello again it has been a while since I had time to do some more troubleshooting on this car .But what I found was it was not holding fuel pressure I found the problem to be the injectors so I replaced them all also I had 8 ouarts of oil and mostley gas in the oil pan .I drained that out and let it dry out a few days replaced with new oil and filter turned on the switch the fuel relay engaged timed out in a few seconds fuel pressure went to 45 psi started the motor it fired right away i let it run for 10 to 15 minutes to build heat I turned it off to check the fluids .I will be changing the oil again Tuesday should I be concerned with all that gas in the oil pan as the engine did run for a little while with all that in the pan but not for more then 10 minutes or so
Reply With Quote
  #8  
Old 04-02-2017, 03:32 PM
craby's Avatar
April 2011 ROTM
ROTM Winner's Club

 
Join Date: Mar 2009
Location: Tokeland, Washington
Posts: 19,977
Default

whats left will evaperate once the engine gets to operating temp and go into the the air intake system through the pcv valve.
Reply With Quote
  #9  
Old 04-02-2017, 05:13 PM
Newbie
Thread Starter
 
Join Date: Dec 2016
Location: Asheville nc
Posts: 27
Default

Hello ok thanks for that info that helps me also after all this when I start the car and let it get up to temp and cut it off it is kinda hard to get it to start back up till it cools off some any ideas or what I should check next
Reply With Quote
  #10  
Old 04-02-2017, 11:02 PM
craby's Avatar
April 2011 ROTM
ROTM Winner's Club

 
Join Date: Mar 2009
Location: Tokeland, Washington
Posts: 19,977
Default

fuel pressure would be one, tired fuel pump can perform poorly once warmed up. ignition module is another, it can fail once warmed up. is it turning over slowly when it wont start or does it turn over the same when trying to start all the time. unhappy starter can lose power once warmed and not turn the engine over fast enough to start, draws to much voltage from the battery
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Fuel Injector or Fuel Pressure Regulator? Kendagenius 93-02 V6 Tech 4 02-05-2017 12:23 PM
fuel pump working no fuel in tb? carmodder 82-92 V8 Tech 9 06-23-2008 12:50 PM
Random fuel gauge + Hard Starts = Bad Fuel pump? BlueKitsune 82-92 General 3 10-05-2007 07:54 PM
Fuel Injector? Fuel Pump? Fuel Filter? G*D Dam Just help me! johnson3034 93-02 V6 Tech 20 05-25-2007 09:35 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 03:33 PM.