electrical problems

  #1  
Old 01-11-2019, 09:31 AM
Newbie
Thread Starter
Join Date: Jan 2019
Posts: 1
Default electrical problems

Rebuilt 305 86 Z28 put it back in choke light on dash will not go out no power to electric choke on carb and charging gauge and temp gauge will not work thanks
 
  #2  
Old 01-12-2019, 08:04 PM
craby's Avatar
April 2011 ROTM
ROTM Winner's Club
Join Date: Mar 2009
Location: Tokeland, Washington
Posts: 20,799
Default

welcome to the forum. moved your thread to the 3rd gen general section for you and we will see if one of the guys can help.
 
  #3  
Old 01-13-2019, 07:03 PM
Camaro 69's Avatar
Senior Moderator
January 2010 ROTM Winner
Join Date: Oct 2007
Location: The 'Burbs of Chicago
Posts: 18,040
Default

Most likely, something is faulty with your charging system or battery/connections. Check all your connections to the alternator and battery. Make sure you have full voltage at the alternator. Check all your grounds. Make sure you have no blown fuses.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
CaliMuscle68
70-81 General
7
03-06-2017 05:33 PM
mp734
93-02 General
2
11-06-2013 11:54 AM
Nightmaro
General Tech
2
10-07-2007 10:33 PM
fellowtraveler87
General Tech
3
10-21-2006 04:17 PM
Dev0415
LT1/LT4 Tech
5
08-29-2006 07:07 PM


Thread Tools
Search this Thread
Quick Reply: electrical problems


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.