Activity Stream: Show All | New Threads | New Posts | New Pictures | Popular Threads | Lonely Threads | Vendor Threads | New Picture Comments | New Profile Comments |
Search:  
Go Back   Camaro Forums - Chevy Camaro Enthusiast Forum > Drivetrain Tech > General Tech
Sign in using an external account
Register Forgot Password?

Closed Thread
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 02-19-2010, 09:59 PM
Newbie
No cars in LiMariee's garage, add now
 
Join Date: Feb 2010
Location: Louisiana
Posts: 29
iTrader: (0)
Send a message via Yahoo to LiMariee
Angry Power Steering Fluid Leak?

Is it going out? It "whines" really bad whenever I turn the wheel. I have only had this car for about 3 days and everyday something new goes out on it. Last night it was the headlight, I spent all day figuring out what to do because with the civic you just pop out the bulb and put in a new one, with this thing you have to take apart the whole freaking headlight! Then, not five minutes later, the stupid steering wheel magically starts whining when I turn. Seriously, how much will this cost me and what does the problem seem to be? I opened the hood, and I just shook my head and shut it again because I don't even know where to start...Help???
  #2  
Old 02-19-2010, 10:03 PM
Newbie
No cars in LiMariee's garage, add now
 
Join Date: Feb 2010
Location: Louisiana
Posts: 29
iTrader: (0)
Send a message via Yahoo to LiMariee
Default

We placed some "puppy pee pee pads" (that you put around the house to train pups) under the car, to see if it was the power steering fluid leaking out, (the chick who had it before me said it might be low) and we found red fluids on the pads. If its something simple or if I said something stupid, don't make me feel stupid, please. This is my first domestic car, and I'm a chick who doesn't know where to start...
  #3  
Old 02-19-2010, 10:33 PM
edog2's Avatar
May 2010 ROTM Winner
ROTM Winner's Club
2010 Chevrolet Camaro
My Garage
 
Join Date: Sep 2009
Location: Harlem, GA
Posts: 632
iTrader: (0)
Default

Did you check the fluid level? I think mine is leaking too, and I just started hearing a squeel. Plus there is fluid splashe all over the place, but cant tell where one leak starts and aother end right now. Pretty sure I had too much in it to start with though.

I hear your pain though. I just put in a tach and when I put my hand on the pass side floor it was soaking wet. I figure heater core popped so I just by passed it until I can check it out for sure.
__________________


1967 with 350, http://www.youtube.com/watch?v=MHUE4eDEjfE
2010 with LS3, http://www.youtube.com/watch?v=Z-Cj1SiC42o
Me vs 2011 Mustang GT (this is the me winning vid)http://www.youtube.com/watch?v=gJPA6G_IHJo&feature=plcp
  #4  
Old 02-19-2010, 10:35 PM
Newbie
No cars in LiMariee's garage, add now
 
Join Date: Feb 2010
Location: Louisiana
Posts: 29
iTrader: (0)
Send a message via Yahoo to LiMariee
Default

yea its killing me. everyday something new goes out...so i'm kinda not liking the camaro thing, and it doesn't help that when i post something to get help, i either don't get responses, or i get smart remarks, so thanks for helping me, its appreciated this coming from a girl who knows nothing about camaros and has to do all of this work to it pretty much on my own, now where do i find the power steering fluid? i never had these problems with my Civic
  #5  
Old 02-19-2010, 10:42 PM
Newbie
No cars in LiMariee's garage, add now
 
Join Date: Feb 2010
Location: Louisiana
Posts: 29
iTrader: (0)
Send a message via Yahoo to LiMariee
Default

dude, i used to drive a honda civic too, and i just got the camaro. stop being a jerk and don't call me a boy. i'm female and i know enough about civics to run you in the dirt, but when it comes to camaros i'm lost. evidently you are in the wrong forum so head on back to the ricer section of the internet, and run yourself off of a cliff. and study some vocabulary because you are lacking in that area. mk thanks.
  #6  
Old 02-19-2010, 10:43 PM
Newbie
No cars in LiMariee's garage, add now
 
Join Date: Feb 2010
Location: Louisiana
Posts: 29
iTrader: (0)
Send a message via Yahoo to LiMariee
Default

quit trollin.
  #7  
Old 02-19-2010, 10:55 PM
edog2's Avatar
May 2010 ROTM Winner
ROTM Winner's Club
2010 Chevrolet Camaro
My Garage
 
Join Date: Sep 2009
Location: Harlem, GA
Posts: 632
iTrader: (0)
Default

Well, mine is alot older than yours and a v8, but its right under the alternator on the front right side on mine. Dont know about the v6. I would imagine it would be pretty much the same looks wise though. The cap would have a dip stick attached to it to see how much is in there. Also it has a belt connected to it to drive the whole deal which on the V8 goes under the fan.
__________________


1967 with 350, http://www.youtube.com/watch?v=MHUE4eDEjfE
2010 with LS3, http://www.youtube.com/watch?v=Z-Cj1SiC42o
Me vs 2011 Mustang GT (this is the me winning vid)http://www.youtube.com/watch?v=gJPA6G_IHJo&feature=plcp

Last edited by edog2; 02-19-2010 at 10:57 PM.
  #8  
Old 02-19-2010, 11:01 PM
Newbie
No cars in LiMariee's garage, add now
 
Join Date: Feb 2010
Location: Louisiana
Posts: 29
iTrader: (0)
Send a message via Yahoo to LiMariee
Default

well when i had the oil changed the other day, the mechanic told me that the belt, which is under what looks like a little space fan type thing (i'm sorry if i sound illiterate) and its a small black belt, idk what it is or what its purpose is but he said that needs to be changed, and i planned on stopping at a gas station on my way to work in the morning and buying some power steering fluid, thanks
  #9  
Old 02-19-2010, 11:04 PM
edog2's Avatar
May 2010 ROTM Winner
ROTM Winner's Club
2010 Chevrolet Camaro
My Garage
 
Join Date: Sep 2009
Location: Harlem, GA
Posts: 632
iTrader: (0)
Default

Click the image to open in full size.

Too late now, I guess you found it.
__________________


1967 with 350, http://www.youtube.com/watch?v=MHUE4eDEjfE
2010 with LS3, http://www.youtube.com/watch?v=Z-Cj1SiC42o
Me vs 2011 Mustang GT (this is the me winning vid)http://www.youtube.com/watch?v=gJPA6G_IHJo&feature=plcp
  #10  
Old 02-19-2010, 11:06 PM
edog2's Avatar
May 2010 ROTM Winner
ROTM Winner's Club
2010 Chevrolet Camaro
My Garage
 
Join Date: Sep 2009
Location: Harlem, GA
Posts: 632
iTrader: (0)
Default

If it is whining all the time or when you start it, probably the belt. If it whines when you turn the wheel probably the pump or fluid. I replaced my alt. belt and pwr steering belt now too long ago because they were kind of old and getting dryed out which led to the noise. But now it seems like low fluid for me too.
__________________


1967 with 350, http://www.youtube.com/watch?v=MHUE4eDEjfE
2010 with LS3, http://www.youtube.com/watch?v=Z-Cj1SiC42o
Me vs 2011 Mustang GT (this is the me winning vid)http://www.youtube.com/watch?v=gJPA6G_IHJo&feature=plcp

Last edited by edog2; 02-19-2010 at 11:08 PM.
Old 02-19-2010, 11:06 PM
Activity Stream
Activity Stream: Show All | New Threads | New Posts | New Pictures | Popular Threads | Lonely Threads | Vendor Threads | New Picture Comments | New Profile Comments |
Search:  
 
 
 
Closed Thread

Tags
2010, 99, camaro, chevy, fluid, leak, leaking, leaks, low, ls1, power, pump, steering, steeting, youtube

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
Our Sponsors


All times are GMT -5. The time now is 06:46 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Emails Backup