Activity Stream: Show All | New Threads | New Posts | New Pictures | Popular Threads | Lonely Threads | Vendor Threads | New Picture Comments | New Profile Comments |
Search:  
Go Back   Camaro Forums - Chevy Camaro Enthusiast Forum > Fourth Generation (1993-2002) > 93-02 Drivetrain > 93-02 V6 Tech
Sign in using an external account
Register Forgot Password?

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-13-2008, 09:21 AM
No cars in jessi78's garage, add now  
Join Date: Jun 2008
Location:
Posts: 1
iTrader: (0)
Default 2000 camaro v6 loses power

My 2000 v6 loses power upon acceleration, bogs down, and sometimes dies, in the middle of the street! It has been dieing every once in awhile for a year if the air is being ran(maybe 1x a week), but it starts back up easy. It is totally worse now, no power upon flooring it i am going 15-20 mph! the check engine light has been on, took it to a shop(no names but they are dumb a#$%es!) they fixed spark plugs, wires, fuel flush, coils, still doing it , told me it was throwing a code for catalytic converter, replaced that, still doing it, replaced fuel filter, still doing it, now they say it is fuel pump??? HELP! I am getting that fixed, they say it is testing bad, ($940!), all together i spent $2000 on this prob!! If this doesn't fix it i am telling them to keep it!!! Any ideas?
Reply With Quote
  #2  
Old 06-13-2008, 09:31 AM
02StanGT's Avatar
Overdrive Member
No cars in 02StanGT's garage, add now
 
Join Date: Sep 2005
Location: Granbury, TX
Posts: 4,053
iTrader: (0)
Send a message via Yahoo to 02StanGT
Default RE: 2000 camaro v6 loses power

Take it to Auto Zone and have them read the codes. It's free. Is it only when the air is on? Any unusual noises?
__________________
'99 Mountaineer AWD 5.0
'09 Impreza WRX

Reply With Quote
  #3  
Old 06-13-2008, 11:42 AM
evilkal's Avatar
4th Gear Member
No cars in evilkal's garage, add now
 
Join Date: Mar 2008
Location: Kentucky
Posts: 1,634
iTrader: (1)
Default RE: 2000 camaro v6 loses power

Mass Air Flow sensooooooooooooor
__________________
Quote:
Originally Posted by Lord Specter
There is no cosmic force behind a simple algebraic equation which may become angered that we did not sacrifice enough virgins and cause our TI-83's to give us wrong numbers.
Reply With Quote
  #4  
Old 06-15-2008, 06:38 AM
1st Gear Member
2002 Chevrolet Camaro
My Garage
 
Join Date: May 2008
Posts: 193
iTrader: (1)
Default RE: 2000 camaro v6 loses power

He's right maybe the Mass flow air sensor because my Elton (named my oldHyundai Accent that cuz it was gaaayyy) did pretty much the same until I replaced it. But also when I took it to Autozone that's exactly what the diagnostic code said it was... good luck
__________________
I'm Branden... a half white half Mexican Camaro lovin' Christian in Tucson, AZ!
Reply With Quote
Old 06-15-2008, 06:38 AM
Activity Stream
Activity Stream: Show All | New Threads | New Posts | New Pictures | Popular Threads | Lonely Threads | Vendor Threads | New Picture Comments | New Profile Comments |
Search:  
 
 
 
Reply

Tags
2000, 99, bogging, bogs, cam, camaro, chevy, filter, fuel, loses, losing, oldhundy, power, v6, wrong

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
Our Sponsors


All times are GMT -5. The time now is 03:41 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Emails Backup